[Appflow Dashboard] Dashboard Access Issues & 504 Errors
Incident Report for Ionic Services
Postmortem

Appflow was completely unavailable for approximately two hours between 12:11 UTC (6:11am CT) and 14:18 UTC (8:18am CT). The outage occurred when a Redis cache ran out of memory due to a task queue growing uncontrollably. We’ve added additional monitoring of the specific queue and fixed the bug causing the large number of tasks to get enqueued.

Posted Jan 13, 2022 - 19:32 UTC

Resolved
The incident has been resolved. Please do contact Ionic support if you are seeing any further issues. Thanks for your patience.
Posted Jan 12, 2022 - 18:06 UTC
Monitoring
A fix has been implemented and the Appflow Dashboard service is now recovering. We will monitor the situation to ensure the problems are resolved. Thanks for your patience.
Posted Jan 12, 2022 - 14:34 UTC
Investigating
We are currently investigating an issue that is resulting in 504 errors for the Ionic Dashboard. This may result in users being unable to access the Dashboard or their applications.
Posted Jan 12, 2022 - 13:16 UTC
This incident affected: Ionic Appflow Dashboard.