Appflow iOS Builds are down
Incident Report for Ionic Services
Postmortem

Appflow production environment experienced an outage, which resulted in Appflow being unable to build iOS Apps.

The incident occurred due to expiration of Ionic’s Certificate Authority (CA)—the trusted entity that ensures secure communications between the worker and controller that orchestrates iOS builds. The CA was mistakenly set to expire causing the workers to no longer communicate with the controller, leading to the disruption.

The incident was resolved by generating a new certificate. To prevent such incidents in the future, Ionic’s CA rotation process is being reviewed for opportunities to increase reliability and security with additional monitoring.

Posted Jun 12, 2024 - 20:24 UTC

Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 20:58 UTC
Monitoring
A fix has been applied that should resolve iOS build failures and we are monitoring the results.
Posted Jun 05, 2024 - 13:42 UTC
Investigating
We are currently investigating an ongoing issue with iOS builds in Appflow.
Posted Jun 05, 2024 - 09:26 UTC
This incident affected: Ionic Appflow Build Service.