Issues authenticating with Azure DevOps in Appflow

Incident Report for Ionic Services

Postmortem

On January 6th, 2026, at 1:53 PM EST, Appflow's Azure DevOps integration stopped working. Customers using Azure DevOps as their git provider were unable to authenticate, link repositories, or run builds. The issue was caused by the expiration of our Azure DevOps OAuth client secret, which had been valid for 5 years since its creation in January 2021. The incident was reported on January 7th, 2026, at 12:27 PM EST, and initially resolved at 3:27 PM EST by rotating the secret and redeploying the authentication service. However, on January 8th, 2026, at 11:04 AM EST, we discovered that builds were still failing because a second service (appflow-apps) also had a copy of the expired secret. Full resolution was confirmed at 12:51 PM EST after updating the secret in both locations.

Posted Jan 13, 2026 - 17:18 UTC

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 14:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.

If you continue to experience issues with builds, please try the following steps:
1. Revoke the Azure DevOps integration in Personal settings > Integrations
2. Reconnect the repository in your app's git settings
3. Push a new commit in your repository
4. Trigger a build from the new commit and confirm whether the cloning process completes successfully

Please reach out to us if the steps above do not resolve the issue.
Posted Jan 07, 2026 - 22:27 UTC

Investigating

Customers using Azure DevOps as their git provider may be unable to link their repositories or complete builds in Appflow. We are looking into the issue and will share updates as we have more information.
Posted Jan 07, 2026 - 18:57 UTC
This incident affected: Ionic Appflow Build Service.