Android Package Builds Failing Due to Missing Dependencies
Incident Report for Ionic Services
Resolved
We have received notice that the missing dependencies that were causing Android build errors should now be restored. Please try your Android builds again and reach out if you continue to have issues.
Posted 4 months ago. Dec 12, 2018 - 20:01 UTC
Update
We have received notice that the missing dependencies that were causing Android build errors should now be restored. Please try your Android builds again and reach out if you continue to have issues.

We are continuing to monitor the situation until we receive verification of successful dependency restoration and build success from our customers.
Posted 4 months ago. Dec 12, 2018 - 13:20 UTC
Update
Our developers have implemented a temporary fix that should allow Android builds to complete successfully while a proper fix is implemented by Google. Please let us know if the issue continues.
Posted 4 months ago. Dec 11, 2018 - 20:11 UTC
Update
Note: This outage is also affecting Creator Package builds.
Posted 4 months ago. Dec 11, 2018 - 13:43 UTC
Update
Missing dependencies are in the process of being restored by Google and the dependency managers. It may still take some time before all dependencies are restored, so we are continuing to monitor the situation.
Posted 4 months ago. Dec 11, 2018 - 13:28 UTC
Monitoring
Over the weekend, we began receiving reports of Android build failures in Ionic Appflow.

We believe the problem relates to the removal of some Android dependencies used for various Android services, plugins, etc. by Google. This issue is not specific to Ionic Appflow or any Ionic service, but it is preventing successful Android Package builds.

Note: We have seen a subset of customers who were able to workaround this issue by upgrading their version of cordova-android to v7.1.4. We recommend customers try upgrading cordova-android to see if that resolves their build problem.

We are monitoring the situation and investigating potential workarounds while awaiting any official updates.
Posted 4 months ago. Dec 10, 2018 - 20:58 UTC
This incident affected: Ionic Appflow Package Service and Ionic Creator (creator.ionic.io).