We're investigating reports of degraded dashboard performance
Incident Report for Ionic Services
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 19, 2018 - 16:53 UTC
Investigating
We are currently investigating this issue.
Posted 9 months ago. Mar 19, 2018 - 14:18 UTC